新規Flexプロジェクトの標準動的Webモジュールバージョン

Flash Builder 4.5プラグインを Eclipseにインストール ( Adobe Flash Builder 4.5アーカイブ解凍中の問題の回避 2011年05月11日、 Adobe Flash Builder 4.5のEclipseプラグイン及び日本語化 2011年5月12日、 本ブログ記事参照) するとFlexプロジェクトの生成が可能になります。 パースペクティブを Java EE から Flash に切り替えれば、
メニュー > ファイル > 新規 > Flex プロジェクト
でアクセス可能です。また切り替えなくても一手間多くなりますが、
メニュー > ファイル > 新規 > その他 > Flash Builder > Flex プロジェクト
でアクセス可能です。

処でこの方法で新規Flex プロジェクトを作成する時に…

スポンサーリンク

特には 動的Webモジュール のバージョンの指定はすることなく作成は終了してしまいます。 生成されたプロジェクトのプロパティーから プロジェクト・ファセット に在る動的Webモジュールのバージョンを確認すると 3.0となっています。 また此処でプルダウンメニューに拠ってバージョンのダウングレードを図ろうとすると、 変更できない旨、表示されてプロジェクトの保存が出来なくなります。

このことに拠って困るのが 動的Webモジュールの3.0では動作しない他プラグインの存在です。 そのプラグインでは具体的には同じくプロジェクト・ファセットの欄で確認すると 必要な動的Webモジュールのバージョンは 2.2,2.3 or 2.4 とされています。 実際そのプラグインのビューに於いて 追加および除去 には此処で新規作成した Flex プロジェクトは表示されません。

現時点ではこの解決法は得られていません。 若しかしたら他プラグインのアップデートを待つしかないのかも知れません。 これも Flash Builder 4 と 4.5 の端境期の宿命でしょうか? 今後情報が得られ次第、ブログ記事にして公開する予定です。

スポンサーリンク